problem with dependency

English speaking general discussion, ideas and suggestions, news, open source development
Avatar de l’utilisateur
Messages : 3
Inscription : 27 Mars 2020, 10:02

problem with dependency

Message par marco.burla » 29 Mars 2020, 16:10

Hi everyone,

I’m Marco, from Italy. I apologize in advance, I have difficulty looking for an answer to my problem in French or English. So why I have opened a new topic.
I have a linuxmmint 19.1 OS installed in a netbook and Lubuntu 19.04. I need OpenBoard to work for school cause the coronavirus lockdown. I tried to download the version of openboard 16 .deb but when I go to install it tells me that the dependencies are not satisfied.
I already have been looking for solutions in google, but I have not made it.
I also tried on my netbook with Linuxmint to directly install the version by the Application Manager. Here it happens that the installation is done, but when I go to open it does not open. Upload for a few seconds and then nothing, no response.
How can I solve it?

Thanks to anyone who can help me.
Greetings, Marco

Avatar de l’utilisateur
Messages : 2
Inscription : 24 Août 2018, 04:42

Re: problem with dependency

Message par e.-wayne.johnson » 05 Avr 2020, 21:56

At this location you can read about a solution developed for Slackware 64-current linux. ... ost6108144

Messages : 2
Inscription : 28 Avr 2020, 06:58

Re: problem with dependency

Message par AngelescuO » 19 Mai 2020, 16:53


Since package is dependent by existing libraries from your's system if package isn't compiled for your's distribution depends won't be satisfied.
The only solution is to compile OpenBoard from sourcesfrom github.
If you try this please read full documentation from OpenBoard website.
I use debian sid/bullseye and succesfully compiled and packaged Openboard about 26 days ago.

I have recompiled Openboard on a fresh debian sid today 20.05.2020.

I have done those instructions from openboard website:
apt-get install git qt5-default libqt5svg5-dev libqt5webkit5-dev libqt5xmlpatterns5-dev qtscript5-dev libssl-dev libpaper-dev libmotif-dev qtmultimedia5-dev qttools5-dev git
git clone
git clone
git clone ... dParty.git
cd OpenBoard-ThirdParty/freetype
qmake -spec linux-g++

cd ../quazip
qmake -spec linux-g++
cd ../xpdf/xpdf-3.04
./configure --with-freetype2-library="../../freetype/lib/linux" --with-freetype2-includes="../../freetype/freetype-2.6.1/include"
cd ..
qmake -spec linux-g++

cd ../../OpenBoard-Importer
qmake -spec linux-g++

cd ../OpenBoard
qmake -spec linux-g++-64

To compile at least in debian sid are needed also
To link you need for those errors the folowing libs :
Error needed library
/usr/bin/ld: cannot find -lva-x11 libva-x11-2
/usr/bin/ld: cannot find -lva libva-dev
/usr/bin/ld: cannot find -lxcb-shm libxcb-shm0-dev
/usr/bin/ld: cannot find -lxcb-xfixes libxcb-xfixes0-dev
/usr/bin/ld: cannot find -lxcb-render ibxcb-render0-dev
/usr/bin/ld: cannot find -lxcb-shape libxcb-shape0-dev
/usr/bin/ld: cannot find -lasound libasound2-dev
/usr/bin/ld: cannot find -lSDL libsdl1.2-dev
/usr/bin/ld: cannot find -lx264 libx264-dev
/usr/bin/ld: cannot find -lvpx libvpx-dev
/usr/bin/ld: cannot find -lvorbisenc libvorbisenc2
/usr/bin/ld: cannot find -lvorbis libvorbis-dev
/usr/bin/ld: cannot find -ltheoraenc libtheora-dev
/usr/bin/ld: cannot find -ltheoradec libtheora-dev
/usr/bin/ld: cannot find -logg libogg-dev
/usr/bin/ld: cannot find -lopus libopus-dev
/usr/bin/ld: cannot find -lmp3lame libmp3lame-dev
/usr/bin/ld: cannot find -lfdk-aac libfdk-aac-dev
/usr/bin/ld: cannot find -lass libass-dev
/usr/bin/ld: cannot find -llzma liblzma-dev
/usr/bin/ld: cannot find -lbz2 libbz2-dev

So you need to install those libraries also using apt-get install .
If compile is succesfull test openboard and if you need a deb package use and scripts.

Thank you
I like Open Source.