Build from source fails

English speaking general discussion, ideas and suggestions, news, open source development
querty
Messages : 1
Inscription : 12 Sep 2019, 16:57

Build from source fails

Message par querty » 12 Sep 2019, 17:04

Hi folks,

I am on Fedora 30 and want to run OpenBoard. Because I could not find any binaries I decided to build it from source as shown here:

https://github.com/OpenBoard-org/OpenBo ... rom-source

I followed the wiki and got to the point where I build the actual tool. But there I get this error:

Code : Tout sélectionner

:244:root@pilgrim-wlan (SB=on)/opt/OpenBoard [0]# /usr/lib64/qt5/bin/qmake-qt5 OpenBoard.pro -spec linux-g++-64
0:245:root@pilgrim-wlan (SB=on)/opt/OpenBoard [0]# make
make -f Makefile.Release
make[1]: Entering directory '/opt/OpenBoard'
/usr/lib64/qt5/bin/uic src/web/browser/downloaditem.ui -o build/linux/release/ui/ui_downloaditem.h
/usr/lib64/qt5/bin/uic src/web/browser/downloads.ui -o build/linux/release/ui/ui_downloads.h
/usr/lib64/qt5/bin/uic src/web/browser/passworddialog.ui -o build/linux/release/ui/ui_passworddialog.h
/usr/lib64/qt5/bin/uic src/web/browser/proxy.ui -o build/linux/release/ui/ui_proxy.h
/usr/lib64/qt5/bin/uic resources/forms/mainWindow.ui -o build/linux/release/ui/ui_mainWindow.h
/usr/lib64/qt5/bin/uic resources/forms/preferences.ui -o build/linux/release/ui/ui_preferences.h
/usr/lib64/qt5/bin/uic resources/forms/brushProperties.ui -o build/linux/release/ui/ui_brushProperties.h
/usr/lib64/qt5/bin/uic resources/forms/documents.ui -o build/linux/release/ui/ui_documents.h
/usr/lib64/qt5/bin/uic resources/forms/blackoutWidget.ui -o build/linux/release/ui/ui_blackoutWidget.h
make[1]: *** No rule to make target 'QtWebKit/QWebView', needed by 'build/linux/release/ui/ui_trapFlash.h'.  Stop.
make[1]: Leaving directory '/opt/OpenBoard'
make: *** [Makefile:42: release] Error 2
0:246:root@pilgrim-wlan (SB=on)/opt/OpenBoard [2]# ll build/linux/release/ui/
total 320K
396856   4K drwx------. 2 root root   4K 2019-09-12 15:15:07.568336581 +0200 ./
396847   4K drwx------. 7 root root   4K 2019-09-12 14:44:59.187284360 +0200 ../
396878   8K -rw-------. 1 root root   5K 2019-09-12 15:15:07.570336587 +0200 ui_blackoutWidget.h
396876  16K -rw-------. 1 root root  16K 2019-09-12 15:15:07.555336544 +0200 ui_brushProperties.h
396877  12K -rw-------. 1 root root  11K 2019-09-12 15:15:07.564336569 +0200 ui_documents.h
396870   8K -rw-------. 1 root root   6K 2019-09-12 15:15:07.503336394 +0200 ui_downloaditem.h
396871   4K -rw-------. 1 root root   4K 2019-09-12 15:15:07.508336408 +0200 ui_downloads.h
396874  72K -rw-------. 1 root root  71K 2019-09-12 15:15:07.530336471 +0200 ui_mainWindow.h
396872   8K -rw-------. 1 root root   5K 2019-09-12 15:15:07.514336425 +0200 ui_passworddialog.h
396875 180K -rw-------. 1 root root 177K 2019-09-12 15:15:07.548336523 +0200 ui_preferences.h
396873   4K -rw-------. 1 root root   4K 2019-09-12 15:15:07.520336443 +0200 ui_proxy.h
0:247:root@pilgrim-wlan (SB=on)/opt/OpenBoard [0]# 
Any help getting OpenBoard to build and run is highly appreciated. So thanks in advance :D

Répondre