Pen Settings

English speaking general discussion, ideas and suggestions, news, open source development
stunidos
Messages : 5
Inscription : 07 Fév 2019, 08:57

Pen Settings

Message par stunidos » 07 Fév 2019, 09:14

Since a while I'm observing the OpenBoard project, and I'd love to use it for my lectures. However, even after testing many versions I still have troubles with the quality of the pen. When the pressure sensitivity is activated, I receive smeared letters. When I switch off the pressure sensitivity, parts of what I write simply doesn't occur on the screen. With other commercial tools, like the PDF Annotator (which I mainly use for my lectures) everything is fine. Also the Microsoft tools like the notes works pretty fine.

I use a ThinkPad X1 Yoga with Wacom AES.
OB-PDFA_Compare.png
OB-PDFA_Compare.png (73.07 Kio) Consulté 2497 fois
In PDF Annotator I'm able to sketch and write pretty fast, OpenBoard I also must write much slower and still the result is not as good. As said I'd love to use OpenBoard because of the better features for lectures. It would be great to understand if there are options in the settings or if there is a bug in combination with my laptop.

stunidos
Messages : 5
Inscription : 07 Fév 2019, 08:57

Re: Pen Settings

Message par stunidos » 25 Mars 2019, 20:21

Sorry for pressing slightly with respect to this subject, however the stylus issue seems to occur for several people (several forum entries) and somehow I think it would be worth to look at this thing, to open the tool up for more users.

In the meantime I tested several settings in Win10, as well as installing different WACOM drivers. However, none of these measures works and I really wonder why even paint reacts faster to the stylus, even though it is certainly not optimized for the stylus usage.

When I use the stylus to write text, the main issue seems to be a little delay when I start to write. As soon as I write text without step, it works. But as soon as I lift the stylus and start a new letter, I again receive the delay. If you look at the example above, you can see that the very first moment of the letters, no curvature is written, but a small straight line. I guess there is a feature in the code which causes the delay. Another observation is, that when I type two dots close to each other and relatively fast, they are connected to a small straight line. So it really looks like a code feature.

As stated above, even MS Paint doesn´t show this problem, hence I guess it´s not a driver issue, but the way the openboard stylus code works. Maybe it´s possible to offer an option to switch (assumed) feature off?

Regards
Peter

c.burisch
Messages : 2
Inscription : 12 Fév 2019, 10:42

Re: Pen Settings

Message par c.burisch » 14 Avr 2019, 18:11

Hello all,

I am seeing this problem also with a Vivitek display. A solution or workaround would be great.

Thank you very much and regards

Christian

TheDrummer
Messages : 4
Inscription : 22 Juin 2018, 13:46

Re: Pen Settings

Message par TheDrummer » 26 Avr 2019, 12:24

Hello,

I can confirm the mentioned observations.

I am using Windows 10 1809 Pro 64-Bit on a Lenovo P40 Yoga with OpenBoard 1.5.2.

I tested different styli (the Lenovo pen, Wacom Bamboo and Wacom Ink), different nib types and different drivers. The type of the pen as well as the nib has no influence on the input performance. What I found is, that the Wacom driver has a big impact but to the worse side. V 7.6.2.10 is a complete mess for the usage with OpenBoard, while V 7.3.4-47 is working with the mentioned problems.

It does not make a significant difference if I change the pens sensitivity and, as Peter stated, for OpenBoard it is better to deactivate pressure sensitivity.

To me it is hard to get a proper handwriting for lectures, especially if I write mathematical expressions with superscripts, greek symbols, integrals, roots, fractions etc. In the beginning I thought this is because I have to learn writing on a tablet, and indeed, in the first months I could improve the quality of my hand written text. But meanwhile I can not evolve the readability and as Peter stated, with other software like OneNote and Windows Journal I achieve much better results.

Another big drawback: occasionally the synchronisation of the stylus tip and screen cursor gets lost. I try to write at the top of the page and the writing occurs at the bottom as undefinite line. Also the tool changes without an action during the writing process e.g. to eraser or to a straight line, which is really anoying for me and my students.

It would be intersting, if these problem also occur with other hardware tahn with Lenevo devices, espeicially, how Microsoft Surface tablets are performing.

Michael

stunidos
Messages : 5
Inscription : 07 Fév 2019, 08:57

Re: Pen Settings

Message par stunidos » 29 Avr 2019, 16:44

Just a final remark, after some more research I figured out, that the basic issue is with "Windows Ink". It depends on the device that is used. When I google for the keywords:

windows stylus delay

then I see various people with the same problem (e.g. https://github.com/drawpile/Drawpile/issues/238 )

So it seems an issue for some propgrams (including Openboard) to handle Windows ink

The solution for me was to get rid of Windows. After installing Ubuntu, now it works perfectly fine for the sam hardware.

Répondre